top of page

The First Year

Public·1 member

Asus Drivers Update Utility License Key.rar

Download File >>>

I have been trying to get my Asus mobile WiFi router running in 8.1, but get the same error code as the motherboard drivers saying "A required software component is missing. (Exception from HRESULT: 0x80131400). when i install the drivers for that also i get the same error message. I have been trying to work this out since yesterday but to no avail. If it is not possible to get these working in windows 8.1 any suggestions would be gratefully received I have a D-Link DWR-022 WISR which worked fine with 8.0 but when i try to install 8.1 it tries to install in win7 compatibility mode which doesnt work on win7 and certainly not on win8.1.

So, I got a new graphics card after buying a motherboard with this cooler ( H77M-HD2). The problem is that the new card is not detected by my system, it seems that the motherboard dont have the right driver, or some sort of drive is missing. I downloaded the bios from Asus and the driver from the manufacturer, I also downloaded the latest driver but when I put them all together, windows says there is a problem with the drivers or something like that

Asus unfortunately is re-releasing the Legacy Driver Package on all the Drivers and Bios Files For All ASUS Original Board. Just Download and Install them and Then, you can Update all your ASUS Original Board. Do try it and if u have any Problems. Regarding ASUS Drivers Update Utility, you can Download them at

hey mark, i got my issue fixed i had already called the asus technical support team, they sent a guy to check the issue and he said that the motherboard needs to be replaced. but when the support guy came with the motherboard, i asked him to reflash the bios (i couldve done it, but didnt do it as my laptop was brand new). he upgraded the bios to the latest version, installed the graphics drivers (intel and nvidia) from asus support site and voila! the sleep issue is gone. now hibernate and sleep are working fine. but the black screen upon restarting still exists (looks like a windows 10 and driver issue i guess). the issue doesnt come when the system is shut down and turned on again. hope this will solve your issue as well. it might be a corrupted bios setting thats causing the issue or the drivers! 3d9ccd7d82


Welcome to the group! You can connect with other members, ge...
bottom of page